Forums

PIC16F84A和"此设备需要固件版本2.1.0或更高版本" message

开始于 2004年6月10日
谢谢你的帮助。 (特别是你的斯科特。)

我很高兴听到我的编程器(R21)可进行FLASH升级。
根据您告诉我的内容,我应该能够从MPLAB IDE进行升级
从“下载PICSTART OS”命令中选择6.40 "Programmer"
菜单。我已经尝试过了,但是似乎什么也没发生。我意识到
由于正在拨号,我的下载速度会很慢,但是在那里
有什么办法可以确定文件是否正在下载?
更好的是,是否可以访问URL以下载文件?

顺便问一下,有什么方法可以搜索该论坛吗?我想要
搜索您的帖子Scott,但搜索功能仅适用于
最后几百个帖子,并且不返回到非常
开始。因此,如果一年中有一些非常相关的职位
以前,我无法联系到他们。



2004年6月10日上午08:55,许冠杰(Jason Hsu)写道:
> >
>好的,除了我无法相信Digi-Key卖给我一个旧的,
>过时的程序员。我应该给你更多的信息以防万一
>有助于。 PICSTART Plus编程器的底部具有
>“可升级Flash”标签。组件号是10-00157-R21,并且 the
>序列号是JIT041411685。

我*认为*您需要升级MPLAB版本。问题是
新的固件更新不适用于旧版本的
MPLAB。 (我认为这是Microchip的一个大错误<sigh>.)

听起来好像您有最新的程序员可用-转到
Microchip并下载MPLAB 6.50。或从您收到的CD安装
与程序员-也应该是6.50。

另一种可能性是您可能需要刷新编程器。再次
在模糊的内存中工作-在MPLAB中的Programmer标头下查看,
选择PicStart Plus,然后“更新固件”或类似的内容 that.

但是,如果要花几分钟以上的时间进行整理,请致电
Microchip的技术支持热线。那些人挺快的
正确的答案。

德韦恩

-
德韦恩·里德(Dwayne Reid)<>
Trinity Electronics Systems Ltd加拿大埃德蒙顿,加拿大
(780)489-3199语音(780)487-6397传真

庆祝工程创新20年(1984年-2004年)
.-。 .-。 .-。 .-。 .-。 .-。 .-。 .-。 .-。 .-
`-'`-'`-'`-'`-'`-'`-'`-'`-'
请勿向该电子邮件地址发送未经请求的商业电子邮件。
此消息均未授予接受未经请求的同意
商业电子邮件,也不旨在征集商业电子邮件。



>顺便说一句,有没有办法我可以搜索这个 forum?

检出名为PGoffline的程序

它将允许您将整个列表存档下载到您的硬盘上
磁盘供您随意查看。

下载整个列表可能需要一些时间,但我很乐意
使用我的版本,看看文件是否可读。

我是Beta测试员,所以我可能有一个不兼容的Verson。

如果是这种情况,我可以让Wilson放一个ZIP版本
官方主页,让您轻松了解。

戴夫



您是否正在使用虚拟COM端口?也就是说,您是否使用USB来 串口设备?我无法让PicStart +与虚拟COM一起使用 port unless I use < V6.xx.
 
尝试搜索“ blueelectron9”或“ electronguy”作为用户名。  我忘了我张贴在哪一个。请注意,我最近才开始发布 that site.
 
最好,
斯科蒂
 
 
- - - 原始信息 - - -
从:
到: p ... @ yahoogroups.com
发送: 6/10/2004 09:50:26
学科: [piclist]关于:PIC16F84A和“此器件需要固件 2.1.0或更高版本”的消息

谢谢你的帮助。 (特别是来自 you, Scott.)

我很高兴听到我的程序员(R21)快闪了 upgradable. 
根据您告诉我的内容,我应该可以从 MPLAB IDE
从“下载PICSTART OS”命令中选择6.40 "Programmer"
菜单。我已经尝试过了,但是似乎什么也没有 发生。我意识到
自从我打开后,我的下载速度会很慢 拨号,但在那里
我可以通过任何方式判断文件是否为 实际下载? 
更好的是,是否有我可以访问的URL,所以我 可以下载文件吗?

顺便说一句,有没有办法我可以搜索这个 论坛?我想要
搜索您的帖子Scott,但是搜索 该功能仅适用于
最近几百个帖子,并且不返回 the very
开始。因此,如果这里有一些非常相关的帖子 year
以前,我无法联系到他们。



到 unsubscribe, go to http://www.yahoogroups.com 和 follow the instructions



我卸载了MPLAB v6.40,并安装了MPLAB v6.50。它没有解决
问题。我仍然收到消息“此设备需要固件
版本2.1.0或更高版本”(当我尝试启用编程器时(从不
请尝试将某些内容加载到其中)。 COM端口连接
看起来还不错,并且我没有使用USB。我的PICSTART Plus是R21
版本,最新版本足以不需要其他芯片
(非常感谢)。

如何检查我拥有的固件版本?我怎么知道
我何时发现固件版本02.01.00和02.10.01?我如何能
知道MPLAB是否正在使用特定版本的固件?我不
以及我应该了解固件。

为什么MPLAB v6.50的固件不适合
基本像PIC16F84A一样开始?

我的背景:
我对微控制器世界是全新的。我没有事先
经验。我正在尝试用一个简单的入门项目完成一个
PIC16F84A,到目前为止,我什至不能这样做。我购买了PICSTART
再加上Digi-Key。我要么是所有杰西卡的母亲
片刻,或有人一直在抽些讨厌的东西。我希望是
前者,因为这对我来说更容易纠正。在那儿
那里有“ PICSTART Plus傻瓜”参考吗?我试过了
PICSTART Plus随附的《 PICSTART Plus用户指南》,
但找不到所需的答案。该指南来自3年前,
而今天的MPLAB似乎与
手册。



您可以尝试从以下渠道购买PIC-MCP编程器 http://www.sparkfun.com 单击“编程器”,向下滚动到“兼容MPLAB” 8/14/18/28/40引脚ZIFF + ICS编程器"“下面的一个是USB /串行 版本。它们可与PIC Start Plus形式的微芯片相媲美。 那就是我与MLAB Ver 6.51一起使用的版本,它支持所有PIC。
 也许固件升级将适用于您的PICSTart Plus。你 可以在这里D / L它。 
http://www.sparkfun.com/tutorial/MCP-Upgrade/MCP-Upgrade.htm

2004年6月10日晚上10:21,您写道:
我卸载了MPLAB v6.40,然后 已安装MPLAB v6.50。它没有解决
问题。我仍然收到消息“此设备需要固件
版本2.1.0或更高版本”(当我尝试启用编程器时(从不
请尝试将某些内容加载到其中)。 COM端口连接
看起来还不错,并且我没有使用USB。我的PICSTART Plus是R21
版本,最新版本足以不需要其他芯片
(非常感谢)。

如何检查我拥有的固件版本?我怎么知道
我何时发现固件版本02.01.00和02.10.01?我如何能
知道MPLAB是否正在使用特定版本的固件?我不
以及我应该了解固件。

为什么MPLAB v6.50的固件不适合
基本像PIC16F84A一样开始?

我的背景:
我对微控制器世界是全新的。我没有事先
经验。我正在尝试用一个简单的入门项目完成一个
PIC16F84A,到目前为止,我什至不能这样做。我购买了PICSTART
再加上Digi-Key。我要么是所有杰西卡的母亲
片刻,或有人一直在抽些讨厌的东西。我希望是
前者,因为这对我来说更容易纠正。在那儿
那里有“ PICSTART Plus傻瓜”参考吗?我试过了
PICSTART Plus随附的《 PICSTART Plus用户指南》,
但找不到所需的答案。该指南来自3年前,
而今天的MPLAB似乎与
手册。
- ---------------------- Yahoo!团体赞助商--------------------〜->
彻底清除弹出广告。雅虎!随播工具栏。
现在有了弹出窗口阻止程序。免费获取!
http://us.click.yahoo.com/L5YrjA/eSIIAA/yQLSAA/dN_tlB/TM
- ------------------------------〜->

取消订阅,请转到 http://www.yahoogroups.com 并按照指示进行

 



我刚刚从sparkfun.com网站下载并运行了.exe文件,
但这还没有解决问题。

Microchip怎么了?他们为什么不能仅仅链接到所有人
固件会在首页上升级,然后放在该页面上
文件链接到固件版本2.1.0、2.1.1等?他们失败了吗
了解即时满足的概念?

我通过电子邮件发送了Microchip的技术支持。希望他们能够
指出我需要的固件升级软件。



您是否检查了帮助>程序中的PICStart Plus菜单?矿
提供完整的故障排除信息和分步说明
升级。

最新的固件是3.11.11,并且所有升级信息都可用
在:
http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId06&dDocName=en010020&part=DV003001

所有软件版本均位于:
http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId95

乍得

- -许冠杰<> wrote:
>我刚刚下载并运行了.exe文件 sparkfun.com site,
>但这还没有解决问题。
>
>Microchip怎么了?他们为什么不能仅仅链接到所有人
>固件会在首页上升级,然后放在该页面上
>文件链接到固件版本2.1.0、2.1.1等?他们失败了吗
>了解即时满足的概念?
>
>我通过电子邮件发送了Microchip的技术支持。希望他们能够
>指出我需要的固件升级软件。


=====
我的软件没有错误。仅未记录的功能。

__________________________________




-在乍得罗素<chadrussel@y...> wrote:
> 您是否检查了帮助> PICStart Plus menu in the program? Mine
>提供完整的故障排除信息并逐步进行
指示
> to upgrade.
>
>最新的固件是3.11.11,所有升级信息是
可用的
> at:
> http://www.microchip.com/stellent/idcplg?
IdcService = SS_GET_PAGE&nodeId06&dDocName=en010020&part=DV003001
>
我已经下载了列出的.zip文件并提取了
psf31100.hex文件放入C:\ Program Files \ MPLAB IDE \ Programmers中。这
没有解决问题。这是这个文件所属的吗?我如何能
判断该文件是否已被MPLAB实际使用?

>所有软件版本均位于:
> http://www.microchip.com/stellent/idcplg?
IdcService = SS_GET_PAGE&nodeId95
>
我的计算机上已经有MPLAB v6.50,并且这个新版本
没有解决这个问题。



Jason,只需将HEX文件下载到您的
硬盘驱动器无法将HEX文件放入
PicStart Plus上的PIC。

PicStart Plus具有板载PIC,
用于正确循环您的线条
待编程的PIC。我们正在谈论
这里有两个PICS。需要固件的那个
升级是焊接到PicStart Plus的一种。
板载PIC。

使用MPLAB,您需要下载
来自PC硬盘的psfs31100.hex文件
进入板载PIC。 MPLAB应该有一个
选择执行此操作。

- -在“许冠杰”中<mailinglist@j...> wrote:
> -在乍得罗素<chadrussel@y...> wrote:
> > 您是否检查了帮助>程序中的PICStart Plus菜单?

> >提供完整的故障排除信息并 step by step
> instructions
> > to upgrade.
> >
> >最新的固件是3.11.11,所有升级信息是
> available
> > at:
> > http://www.microchip.com/stellent/idcplg?
> IdcService = SS_GET_PAGE&nodeId06&dDocName=en010020&part=DV003001
> >
>我已经下载了列出的.zip文件并提取了
>psf31100.hex文件放入C:\ Program Files \ MPLAB IDE \ Programmers中。

>没有解决问题。这个文件在哪里 belongs? How do
I
>告诉此文件是否实际被 MPLAB?
>
> >所有软件版本均位于:
> > http://www.microchip.com/stellent/idcplg?
> IdcService = SS_GET_PAGE&nodeId95
> >
>我的计算机上已经有MPLAB v6.50,并且这个新版本
>没有解决这个问题。